Cruise control does not work - Subaru Forester Owners Forum
User Tag List

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 6 (permalink) Old 01-30-2006, 10:39 PM Thread Starter
Forum Member
 
GIT-R-DONE's Avatar
 
Join Date: Jan 2006
Location: Victoria Harbour Ontario
Posts: 1,778
Car Year: 2010
Car Model: dodge caravan
Transmission: auto
Cruise control does not work

my Cruise control stoped working, any ideas why?? is it a fuse, relay or other. It did work fine a month ago. If it is a fuse or relay were is it. (I would check my self but its cold outside and I'm lazy :p ) its a 2002 S sport 2.5 n/a

GIT-R-DONE
2010 Dodge grand caravan SE
2002 S sport 5spd SOLD
1996 L Legacy AWD
GIT-R-DONE is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 02-03-2006, 06:23 AM
jumajigger
Guest
 
Posts: n/a
hopefully a different problem than listed in the previous cc thread
post #3 of 6 (permalink) Old 02-03-2006, 07:03 AM
Contributing Member
 
ferret's Avatar
 
Join Date: Jan 2006
Location: Northern NJ
Posts: 3,356
Car Year: 2014
Car Model: Impreza Ltd
Transmission: CVT
Does the switch lightup when the Cruise Control switch is pushed?
If not I would start by checking fuses 16 and 18. After that my next checks would include the brakelight switch (and clutch switch if a manual). Then the cruise switch and switch on steering wheel (also could be the 'rolled coil' or clockspring). Also check the vacuum line to the actuator under the hood as well as the cable from the actuator to the throttle lever. And ANY connectors, cables or components in between.

Next would be the main components, the actuator assy itself, or the cruise control module.

98S, 2014 Impreza 5 dr Ltd (9 Subaru's since 1978, 7 were 5 sp) ILuvSubaru's
ferret is offline  
post #4 of 6 (permalink) Old 02-03-2006, 03:37 PM
#8 Post ho
 
SenorSubie's Avatar
 
Join Date: Jan 2006
Location: Eau Claire Wisconsin
Posts: 2,542
Car Year: 1999
Car Model: Subaru Forester
My cruise works but there's no light on the switch

99 AT-
wrx goodies
Subiegal Gauge Pod
SenorSubie is offline  
post #5 of 6 (permalink) Old 08-03-2006, 09:25 PM
technokoz
Guest
 
Posts: n/a
There's a light? I guess I need to fix that too.

My cruise is very hard to set. I think the main switch is bad. I can't cancel it there and it sometimes takes a minute of wiggling the switch to finally get it to set. I don't travel much, so its never bothered me enough to fix. I might just call around to the junk yards to find out how much a replacement switch would be. I haven't looked at the manual to see what's involved in replacing. I doubt much.
post #6 of 6 (permalink) Old 08-04-2006, 05:31 PM
Forum Member
 
Hondaslayer's Avatar
 
Join Date: Jan 2006
Location: Auburn, WA
Posts: 2,072
Car Year: 1998
Car Model: Forester "S" lifted.
Transmission: Bog-o-matic
Can you turn on the system (hit button and the cruise indicator comes on) but cannot accelerate, set etc....??? If so it is probably your roll connector. Common enough. The other tell-tale sign is when your horn stops blowing ;)

It's real velour. Just let yourself go!
Hondaslayer is offline  
Sponsored Links
Advertisement
 
Reply

  Subaru Forester Owners Forum > Technical Forums and Vehicle Assistance > Problems, Maintenance, and Warranty

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Subaru Forester Owners Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome