Cruise control does not work - Subaru Forester Owners Forum
Subaru Forester Forum
ebay search
Subaru Forester Forum
Go Back   Subaru Forester Owners Forum > Technical Forums and Vehicle Assistance > Problems, Maintenance, and Warranty
SubaruForester.org is the premier Subaru Forester Forum on the internet. Registered Users do not see the above ads.
User Tag List

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 01-30-2006, 09:39 PM   #1 (permalink)
Forum Member
 
GIT-R-DONE's Avatar
 
Join Date: Jan 2006
Posts: 1,778
Location: Victoria Harbour Ontario
Car Year: 2010
Car Model: dodge caravan
Transmission: auto
Gallery: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 2 reviews
Default Cruise control does not work

my Cruise control stoped working, any ideas why?? is it a fuse, relay or other. It did work fine a month ago. If it is a fuse or relay were is it. (I would check my self but its cold outside and I'm lazy :p ) its a 2002 S sport 2.5 n/a
__________________
GIT-R-DONE
2010 Dodge grand caravan SE
2002 S sport 5spd SOLD
1996 L Legacy AWD
GIT-R-DONE is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-03-2006, 05:23 AM   #2 (permalink)
jumajigger
Guest
 
Posts: n/a
Gallery:
Mentioned: Post(s)
Tagged: Thread(s)
Quoted: Post(s)
Default

hopefully a different problem than listed in the previous cc thread
  Reply With Quote
Old 02-03-2006, 06:03 AM   #3 (permalink)
Contributing Member
Supporting Member
 
ferret's Avatar
 
Join Date: Jan 2006
Posts: 3,354
Location: Northern NJ
Car Year: 2014
Car Model: Impreza Ltd
Transmission: CVT
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Feedback Score: 6 reviews
Default

Does the switch lightup when the Cruise Control switch is pushed?
If not I would start by checking fuses 16 and 18. After that my next checks would include the brakelight switch (and clutch switch if a manual). Then the cruise switch and switch on steering wheel (also could be the 'rolled coil' or clockspring). Also check the vacuum line to the actuator under the hood as well as the cable from the actuator to the throttle lever. And ANY connectors, cables or components in between.

Next would be the main components, the actuator assy itself, or the cruise control module.
__________________
98S, 2014 Impreza 5 dr Ltd (9 Subaru's since 1978, 7 were 5 sp) ILuvSubaru's
ferret is online now   Reply With Quote
Old 02-03-2006, 02:37 PM   #4 (permalink)
#8 Post ho
 
SenorSubie's Avatar
 
Join Date: Jan 2006
Posts: 2,542
Location: Eau Claire Wisconsin
Car Year: 1999
Car Model: Subaru Forester
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 3 reviews
Default

My cruise works but there's no light on the switch
__________________
99 AT-
wrx goodies
Subiegal Gauge Pod
SenorSubie is offline   Reply With Quote
Old 08-03-2006, 08:25 PM   #5 (permalink)
technokoz
Guest
 
Posts: n/a
Gallery:
Mentioned: Post(s)
Tagged: Thread(s)
Quoted: Post(s)
Default

There's a light? I guess I need to fix that too.

My cruise is very hard to set. I think the main switch is bad. I can't cancel it there and it sometimes takes a minute of wiggling the switch to finally get it to set. I don't travel much, so its never bothered me enough to fix. I might just call around to the junk yards to find out how much a replacement switch would be. I haven't looked at the manual to see what's involved in replacing. I doubt much.
  Reply With Quote
Old 08-04-2006, 04:31 PM   #6 (permalink)
Forum Member
 
Hondaslayer's Avatar
 
Join Date: Jan 2006
Posts: 2,072
Location: Auburn, WA
Car Year: 1998
Car Model: Forester "S" lifted.
Transmission: Bog-o-matic
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
Default

Can you turn on the system (hit button and the cruise indicator comes on) but cannot accelerate, set etc....??? If so it is probably your roll connector. Common enough. The other tell-tale sign is when your horn stops blowing ;)
__________________
It's real velour. Just let yourself go!
Hondaslayer is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Subaru Forester Owners Forum > Technical Forums and Vehicle Assistance > Problems, Maintenance, and Warranty

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:48 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.