Bosch D3300 Oil Filter - Subaru Forester Owners Forum
User Tag List

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 3 (permalink) Old 09-19-2011, 06:48 AM Thread Starter
Forum Member
 
jbbst13's Avatar
 
Join Date: Sep 2009
Location: Pittsburgh, PA
Posts: 23
Car Year: 2010
Car Model: Forester 2.5X
Feedback Score: 0 reviews
Bosch D3300 Oil Filter

I have a 2010 Forester 2.5 X and was due for an oil change. I got up early, went to the local parts store, and headed home to start the work. Once all the oil was drained and the old filter removed, I was ready to install the new Bosch filter. I lined it up and started to turn, and it wouldn't thread on. After several repeated attempts, I looked at the filter and it was stamped with 3/4-16 above the threaded hole...so the threads didn't line up! From what I remember reading on this forum, the threads on the stud are M20. I ended up walking back to the parts store to get a Mobil 1 filter and had no issues.

I wanted to mention this because at Advance Auto, this is listed as one of the replacement filters and I saw other posts on this forum where people had used it. So, I'm not sure if it was the wrong part in the box or a quality issue...either way, it wouldn't work!

I wasn't sure which forum this should be in, so feel free to move it to the correct spot.

2010 Forester 2.5 X, 4 EAT
Obsidian Black Pearl
jbbst13 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 09-19-2011, 06:54 AM
Super Moderator
 
flstffxe's Avatar
 
Join Date: Dec 2007
Location: Coon Rapids, MN
Posts: 7,836
Car Year: 2008
Car Model: Forester X Premium
Transmission: 5MT
Feedback Score: 1 reviews
It would seem that the filter you got either has the wrong label on it or was assembled with the incorrect base plate. Rare but it happens, it is a manufactured product and everyone makes mistakes.

20 x 1.5mm is the correct thread.

His - 08 X Prem 5mt
Hers - 08 X 4EAT
flstffxe is offline  
post #3 of 3 (permalink) Old 09-19-2011, 07:18 AM Thread Starter
Forum Member
 
jbbst13's Avatar
 
Join Date: Sep 2009
Location: Pittsburgh, PA
Posts: 23
Car Year: 2010
Car Model: Forester 2.5X
Feedback Score: 0 reviews
Quote:
Originally Posted by flstffxe View Post
It would seem that the filter you got either has the wrong label on it or was assembled with the incorrect base plate. Rare but it happens, it is a manufactured product and everyone makes mistakes.

20 x 1.5mm is the correct thread.
Thanks! I kinda figured that's what happened, and I'm glad I read the post right on the thread size!

2010 Forester 2.5 X, 4 EAT
Obsidian Black Pearl
jbbst13 is offline  
Sponsored Links
Advertisement
 
Reply

  Subaru Forester Owners Forum > Technical Forums and Vehicle Assistance > Problems, Maintenance, and Warranty

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome