('03-'05) turn signal stays on - Subaru Forester Owners Forum
Subaru Forester Forum
ebay search
Subaru Forester Forum
Go Back   Subaru Forester Owners Forum > Technical Forums and Vehicle Assistance > Lighting and Electrical
SubaruForester.org is the premier Subaru Forester Forum on the internet. Registered Users do not see the above ads.
User Tag List

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 06-25-2011, 09:27 AM   #1 (permalink)
Registered User
 
Join Date: Dec 2009
Posts: 2
Location: germany
Car Year: 2003
Car Model: forester
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Default turn signal stays on

My 03 Forester left turn signal works fine until I turn the headlights on. Than the green arrow on the dash lights up and stays lite and also the front and rear turn lights stay lite but don't blink. Than when I turn off the head lights the turn signal goes back to working the way it should always. Are there any good ideas of what could be causing this. My car is US specs but I'am stationed in Germany and the car is due for inspection and I hate to have the Germans work on it because they think Americans all have money and they want to get as much out of us as possible. Thanks for any help.
Billy
billy56 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-25-2011, 09:54 AM   #2 (permalink)
Forum Member
 
orienteer's Avatar
 
Join Date: Jan 2006
Posts: 954
Location: Uxbridge, London, UK
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Default

Would suspect a bad earth in the LH front light unit. Check for loose or corroded earth connections.
__________________
2011 Forester XC Diesel
Moulton bicycles
orienteer is offline   Reply With Quote
Old 07-04-2011, 03:34 PM   #3 (permalink)
Taking a Walkabout in the Outback
 
Join Date: May 2011
Posts: 669
Car Year: ...
Car Model: ...
Transmission: ...
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Default

Flasher unit needs replacing, unplug and replace, easy, relatively cheap also.
Georgie is offline   Reply With Quote
Old 05-19-2013, 06:37 AM   #4 (permalink)
Forum Member
 
Join Date: May 2013
Posts: 4
Location: up state NY
Car Year: 2004
Car Model: forester
Transmission: automatic
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Default Did you ever find the problem?

I have the same problem. I ran all new grounds, replaced all the bulbs, changed the combination switch, and the flasher, but the problem persists. Did you ever find out what you issue was?
tech56jg is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Subaru Forester Owners Forum > Technical Forums and Vehicle Assistance > Lighting and Electrical

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:42 AM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.