('03-'05) turn signal stays on - Subaru Forester Owners Forum
User Tag List

 
LinkBack Thread Tools Search this Thread Display Modes
post #1 of 4 (permalink) Old 06-25-2011, 09:27 AM Thread Starter
Forum Member
 
Join Date: Dec 2009
Location: germany
Posts: 2
Car Year: 2003
Car Model: forester
Feedback Score: 0 reviews
turn signal stays on

My 03 Forester left turn signal works fine until I turn the headlights on. Than the green arrow on the dash lights up and stays lite and also the front and rear turn lights stay lite but don't blink. Than when I turn off the head lights the turn signal goes back to working the way it should always. Are there any good ideas of what could be causing this. My car is US specs but I'am stationed in Germany and the car is due for inspection and I hate to have the Germans work on it because they think Americans all have money and they want to get as much out of us as possible. Thanks for any help.
Billy
billy56 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 06-25-2011, 09:54 AM
Forum Member
 
orienteer's Avatar
 
Join Date: Jan 2006
Location: Uxbridge, London, UK
Posts: 1,068
Car Year: 2014
Car Model: XE
Transmission: CVT
Feedback Score: 0 reviews
Would suspect a bad earth in the LH front light unit. Check for loose or corroded earth connections.
orienteer is offline  
post #3 of 4 (permalink) Old 07-04-2011, 03:34 PM
Taking a Walkabout in the Outback
 
Join Date: May 2011
Posts: 669
Car Year: ...
Car Model: ...
Transmission: ...
Feedback Score: 0 reviews
Flasher unit needs replacing, unplug and replace, easy, relatively cheap also.
Georgie is offline  
post #4 of 4 (permalink) Old 05-19-2013, 06:37 AM
Forum Member
 
Join Date: May 2013
Location: up state NY
Posts: 4
Car Year: 2004
Car Model: forester
Transmission: automatic
Feedback Score: 0 reviews
Did you ever find the problem?

I have the same problem. I ran all new grounds, replaced all the bulbs, changed the combination switch, and the flasher, but the problem persists. Did you ever find out what you issue was?
tech56jg is offline  
Sponsored Links
Advertisement
 
Reply

  Subaru Forester Owners Forum > Technical Forums and Vehicle Assistance > Lighting and Electrical

Thread Tools Search this Thread
Show Printable Version Show Printable Version
Email this Page Email this Page
Search this Thread:

Advanced Search
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome