What did you do to your subie today? - Page 384 - Subaru Forester Owners Forum
Subaru Forester Forum
ebay search
Subaru Forester Forum
Go Back   Subaru Forester Owners Forum > General Forums > General Forum
SubaruForester.org is the premier Subaru Forester Forum on the internet. Registered Users do not see the above ads.
User Tag List

Reply
 
LinkBack Thread Tools Search this Thread Display Modes
Old 11-17-2012, 10:34 PM   #5746 (permalink)
Forum Member
 
Join Date: May 2012
Posts: 175
Location: Northeast wisconsin
Car Year: 2004
Car Model: 2.5xs
Transmission: dont know how to drive auto
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
Default

I think my timing belt broke.....
EffenBee is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-17-2012, 11:04 PM   #5747 (permalink)
Forum Member
 
Join Date: Aug 2012
Posts: 15
Location: Davis, California
Car Year: 2005
Car Model: Forester XT Limited
Transmission: Manual
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Default

Had the oil cooler leak fixed and an oil change/tire rotation at the dealer, 8 miles later became a racquet ball between walls :( so sad.

Sent from my A500 using Tapatalk 2
Attached Thumbnails
What did you do to your subie today?-uploadfromtaptalk1353225748277.jpg   What did you do to your subie today?-uploadfromtaptalk1353225759974.jpg  
spiked_FXT is offline   Reply With Quote
Old 11-18-2012, 02:11 AM   #5748 (permalink)
Forum Member
Lifetime Supporting Member
 
k3nj11's Avatar
 
Join Date: Apr 2010
Posts: 2,568
Location: Seattle, WA
Car Year: 2007
Car Model: 2.5 XT Limited
Transmission: 5-spd's of DOOM!
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 18 Post(s)
Feedback Score: 8 reviews
Default

Quote:
Originally Posted by spiked_FXT View Post
Had the oil cooler leak fixed and an oil change/tire rotation at the dealer, 8 miles later became a racquet ball between walls :( so sad.

Sent from my A500 using Tapatalk 2
Oh no....what happened??
k3nj11 is online now   Reply With Quote
Old 11-18-2012, 05:37 AM   #5749 (permalink)
Super Moderator
 
Loscaldazar's Avatar
 
Join Date: Jun 2011
Posts: 3,076
Location: Plymouth, Minnesota
Car Year: 03
Car Model: Forester
Transmission: 5 MT
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Feedback Score: 7 reviews
Default

Yesterday drove 250 miles and got 24 MPG on winter gas with 10% ethanol @75 MPH. Prepping to go back today!
__________________
2003 Forester 2.5XS Mod Journal
Loscaldazar is online now   Reply With Quote
Old 11-18-2012, 11:07 AM   #5750 (permalink)
Forum Member
 
Chow40cal's Avatar
 
Join Date: Jul 2012
Posts: 467
Location: Tacoma, WA
Car Year: 03
Car Model: Whorester
Transmission: 4EAT
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Feedback Score: 2 reviews
Default

Green pad the windows and sun roof with Goo Gone to get rid of that nasty tree sap, then she got her windows coated in Rain-X!


Sent from my iPhone using AutoGuide.com Free App
__________________
Chow40cal on Flickr and Instagram
Chow40cal is offline   Reply With Quote
Old 11-18-2012, 11:37 AM   #5751 (permalink)
Forum Member
 
Join Date: Aug 2012
Posts: 15
Location: Davis, California
Car Year: 2005
Car Model: Forester XT Limited
Transmission: Manual
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Default

Quote:
Originally Posted by k3nj11 View Post
Oh no....what happened??
I don't know really. Car got light in a turn (doing the posted speed w/ the flow of traffic, not hot rodding), when it gripped it was too far past center so it put me into a spin the opposite direction. On an interchange that was 2 lanes wide w/ concrete walls on both sides and no shoulder, spun off of both walls.
I'm waiting until Monday to get back to the car that is parked in a body shop, I'm curious if the dealer over inflated my tires when they rotated them and did the maint.
Otherwise, I'm at a loss as to how this happened.

Finally got one of my realistic dream cars and this happens less then 6 months in
spiked_FXT is offline   Reply With Quote
Old 11-18-2012, 02:14 PM   #5752 (permalink)
Forum Member
 
Lazer's Avatar
 
Join Date: Aug 2010
Posts: 482
Location: Chicago
Car Year: 2005
Car Model: FXT 5spd
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 8 reviews
Default

Yes, it has been awhile since I actually did anything to my Foz. The other day after work I pulled it into the porter's wash area (I work at a dealership) and gave it a thorough washing. It had been about 3 months and it looks better than ever after I got all the grime out of the interior too. Waxed the hood and rear bumper to try and get out a couple of scuffs, but I need to have a real detail done to it with a proper buff and nice rubbing compounds, etc. to really bring my paint back to life. Did manage to get my RPF1s looking amazing though! No more brake dust and grime on them! Going to be swapping them out for my winter wheels/tires soon. Also, going to be putting the stock seats back in as they are heated and the days aren't getting any warmer here in Chicago!
__________________
My 05 FXT Build Thread
Lazer is offline   Reply With Quote
Old 11-18-2012, 03:01 PM   #5753 (permalink)
SF.org Hero
 
sleestak's Avatar
 
Join Date: Jun 2010
Posts: 651
Car Year: 04
Car Model: FXTi
Transmission: 5MT
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Feedback Score: 6 reviews
Default

Installed 850cc injectors, hooked up grimmspeed bcs and got her tuned for 93 and e85.
sleestak is offline   Reply With Quote
Old 11-18-2012, 05:40 PM   #5754 (permalink)
Forum Member
 
foresterthirst's Avatar
 
Join Date: Nov 2011
Posts: 117
Location: Philadelphia
Car Year: '12
Car Model: 2.5x Premium
Transmission: 4spd
Gallery: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
Default

drained old oil and put in 6 qts of Idemitsu 0w-20 w/ new 160 filter.
foresterthirst is offline   Reply With Quote
Old 11-18-2012, 05:56 PM   #5755 (permalink)
Forum Member
 
Nthads's Avatar
 
Join Date: Jul 2011
Posts: 115
Location: Rhode Island
Car Year: 2003
Car Model: Forester XS
Transmission: 4EAT
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 2 reviews
Default

Just changed my PCV valve(which is now causing a rattling sound) and trying to hunt down a metalish sounding whistle around 4k rpm... Any thoughts?
Nthads is offline   Reply With Quote
Old 11-18-2012, 06:11 PM   #5756 (permalink)
SF.org Hero
 
sleestak's Avatar
 
Join Date: Jun 2010
Posts: 651
Car Year: 04
Car Model: FXTi
Transmission: 5MT
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Feedback Score: 6 reviews
Default

Quote:
Originally Posted by Nthads View Post
Just changed my PCV valve(which is now causing a rattling sound) and trying to hunt down a metalish sounding whistle around 4k rpm... Any thoughts?
a leak somewhere causing the whistle? Hopefully not a big ol vacuum leak causing you to ping -metalic rattling sound. Wouldnt happen to sound like bb's in a coffee can would it?
sleestak is offline   Reply With Quote
Old 11-18-2012, 06:15 PM   #5757 (permalink)
Forum Member
 
Nthads's Avatar
 
Join Date: Jul 2011
Posts: 115
Location: Rhode Island
Car Year: 2003
Car Model: Forester XS
Transmission: 4EAT
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 2 reviews
Default

.... not entirely sure cant replicate it when in park and under the hood......even had my scangauge II flipped around watching my RPMs as I messed with the throttle up and down under the hood to 4k and nothing....
Nthads is offline   Reply With Quote
Old 11-18-2012, 06:19 PM   #5758 (permalink)
Forum Member
 
Nthads's Avatar
 
Join Date: Jul 2011
Posts: 115
Location: Rhode Island
Car Year: 2003
Car Model: Forester XS
Transmission: 4EAT
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 2 reviews
Default

also it only happens in gear at 4k when on the throttle and goes away over 4.5k so also makes it slightly difficult to locate unless im getting on it to avoid a big rig getting on the highway.... or running late....
Nthads is offline   Reply With Quote
Old 11-18-2012, 07:02 PM   #5759 (permalink)
Forum Member
 
Mr_Wrong's Avatar
 
Join Date: Aug 2012
Posts: 14
Location: Rhode Island
Car Year: 2011
Car Model: Forester
Transmission: 4EAT
Gallery: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Default USB

I didn't like where the USB and 3.5mm AUX ports were so I put the whole piece they sit in underneath the console and ran extender wires to the front. I put them through the hole next to little blue ambient light. They're just hanging out right now but maybe I'll fashion something for them to live in. For now it's still better than it was.
Mr_Wrong is offline   Reply With Quote
Old 11-18-2012, 07:09 PM   #5760 (permalink)
Forum Member
 
forester06x's Avatar
 
Join Date: Nov 2011
Posts: 2,896
Location: Memphis TN
Car Year: 2006
Car Model: X Supercharged
Transmission: 4.11 5MT Swap
Gallery: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 29 Post(s)
Feedback Score: 7 reviews
Default

Changed spark plugs to NGK Iridium IX, straightforward install and only took 1 hour for it being my first time. It was a bit cramped on the driver's side so I used a socket U-joint extension and it was all good. I only removed the air filter box, not the battery or anything else. Bad news is I need to replace my valve cover gaskets. :sad:

Also while replacing my belts I broke the idler pulley tensioner.

__________________
5MT Swapped & Supercharged '06- The GolfBall
forester06x is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Subaru Forester Owners Forum > General Forums > General Forum

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 12:19 PM.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
User Alert System provided by Advanced User Tagging v3.1.0 (Pro) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.